世纪电源网社区logo
社区
Datasheet
标题
返回顶部
讨论

图腾柱PFC过流报警问题询问

[复制链接]
查看: 590 |回复: 32
1
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-7-30 10:51:01
大家好,我在弄一个1600W的图腾柱PFC设计,板子调试时总是过流报警,然后直接停止工作了。但是检测电阻采样的运放输出端,并没有检测到那么大的电流过流,具体怎么解决呢?
YTDFWANGWEI
  • 积分:97261
  • |
  • 主题:139
  • |
  • 帖子:43350
积分:97261
版主
  • 2018-7-30 13:07:49
 
你的过流告警是如何保护的?硬件还是软件?
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-10 11:15:38
 
是软件报警,软件设置的是19A过流报警,可是不可能有那么大电流,开始以为死区没做的,后面采用了100ns和50nS的死区,情况是一样的。所以排除了死区影响。

slslsl651
  • 积分:1913
  • |
  • 主题:27
  • |
  • 帖子:624
积分:1913
LV6
高级工程师
  • 2018-8-10 12:06:56
 
你用的什么管子,100ns的死区会不会太小?
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-29 15:24:17
  • 倒数3
 
淡化镓的管子,开通速度和关闭速度都在50ns以内
YTDFWANGWEI
  • 积分:97261
  • |
  • 主题:139
  • |
  • 帖子:43350
积分:97261
版主
  • 2018-8-11 08:34:10
 
软件报警,那就实际测量电流检测信号,确定没有过流,就找软件的问题,应该还有A/D转换的问题好了。
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-29 15:15:40
  • 倒数5
 
是硬件问题,拆掉一个电容就行。
nc965
  • 积分:44729
  • |
  • 主题:113
  • |
  • 帖子:14705
积分:44729
版主
  • 2018-7-30 16:59:49
 
谨慎布线
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-10 11:16:06
 
布线算比较谨慎了,走了两次板子,情况都是一样的。
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-10 11:19:41
 
你看附图里面的电流采样,我在运放OPA188末端检测到好大的干扰,可是不知道这个干扰应该是在第一级运放INA826那里放大过来的,还是说是后面运放OPA188的输入滤波没做好的?
我应该怎么滤波呢?滤波参数是怎么确定的?
企业微信截图_15338705578763.png
deep_thought
  • 积分:3885
  • |
  • 主题:0
  • |
  • 帖子:824
积分:3885
LV8
副总工程师
  • 2018-8-10 11:58:15
 
可以尝试短路C68,看看是否还误保护,定位问题点。
可能的原因:
1. 控制电路有问题,导致开关管瞬间大电流直通,引起巨大噪声,触发保护。
2. 电流取样放大电路地线处理不好。
3. 电流取样放大电路太靠近功率回路。
4. 电流取样放大电路滤波不好。

Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-16 10:32:32
 
找到问题了,AD采样口那个电容造成采样延时,同时驱动MOS电阻取值不合理,关闭的电阻太小了,把0欧姆改为20欧姆问题就解决了。目前在55VAC输入,120V输出时没有问题,可以带上200W多。但是,上了高压输出就不行了,测量一下,还是驱动问题,GaN的驱动不好做,开通速度太快了。谢谢
楼主的回答。
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-16 10:39:58
 
附件中图片就是上到高压后的电流波形,可以看到在开关切换时,有电流尖峰。测量了图腾柱GaN_MOS下管关闭后有小幅震荡,估计是震荡导致GaN管二次导通了。GaN管的导通阈值是1.2V,请问大神有什么办法处理掉这个震荡?GaN的开通速度是25-50ns,关闭速度是15-20ns。
z8-16-1.jpg
deep_thought
  • 积分:3885
  • |
  • 主题:0
  • |
  • 帖子:824
积分:3885
LV8
副总工程师
  • 2018-8-16 13:46:20
 
GaN,我没有用过哦。不熟悉。可以用一点点负压关断不?
什么电路结构?半桥或全桥?可以通过改驱动电阻让开通慢一点,关断快一点的方式不?
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-16 17:04:38
 
半桥结构,如上图所示。Gan1和GaN2是氮化镓MOS管,我检测到震荡就是GaN开通速度太快,Dv/Dt太大造成的震荡。GaN的开通时间不到10ns,加大电阻貌似对开通速度延时影响不大,大于100欧姆的开通电阻还会造成驱动波形畸形,欠驱动会烧管咧。另外提一下,关断过程由于电感会使得中点电压变化缓慢,所以不会造成电路震荡。
图腾柱PFC概率截图.png
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-16 17:26:02
 
我觉得有负压或许有点用,因为GaN的导通电压阈值是1V左右,用负压可以避免震荡造成的二次导通,但是负压要改电路,有点麻烦,看看有没有其他解决办法先。
deep_thought
  • 积分:3885
  • |
  • 主题:0
  • |
  • 帖子:824
积分:3885
LV8
副总工程师
  • 2018-8-17 13:14:29
 
你需要详细分析这个振铃的产生的根本原因。比如:
1. 是否有上下桥共通。或者你提到的二次导通引起。
2. 是否由硬开关导致。能否加大吸收电路电容解决。
3. 是否电感的寄生电容太大。

Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-29 15:18:31
  • 倒数4
 
估计是有上下导通问题了。
【1】在上下管开通时刻,另外一个管子G极会有电压上翘的情况。
【2】在第一点中电压上翘其实就是弥勒效应影响的。
【3】弥勒效应影响就是在硬开关里面才体现出来。
deep_thought
  • 积分:3885
  • |
  • 主题:0
  • |
  • 帖子:824
积分:3885
LV8
副总工程师
最新回复
  • 2018-8-31 08:02:29
  • 倒数1
 
恩。
nc965
  • 积分:44729
  • |
  • 主题:113
  • |
  • 帖子:14705
积分:44729
版主
  • 2018-8-16 14:21:14
 
1、二极管再用好一点
2、开通再放软一点
3、Ip回路串一个饱和电感
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-16 17:24:29
 
这个是氮化镓MOS管,没有用反向二极管。问题就是开通太快了,可是改变开通电阻无法大幅增加开通时间,目前开通时间约为10ns。第三点的Ip是指升压电感么?第三点不太理解。我觉得处理IP应该是没有用的,因为不是电感的造成的,应该是下管开通太快影响上管;或者是上管开通太快,影响下管。
nc965
  • 积分:44729
  • |
  • 主题:113
  • |
  • 帖子:14705
积分:44729
版主
  • 2018-8-16 20:48:24
 
用MOS代替二极管,即使是氮化镓也是不妥的,同步整流高压下优势不大。
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-20 21:56:00
 
GaN的内部二极管可以耐受电流很大的,实际测量可以过20A,而我也用不到20A,当然反向导通时间是很短的,我死区只做100ns。
nc965
  • 积分:44729
  • |
  • 主题:113
  • |
  • 帖子:14705
积分:44729
版主
  • 2018-8-20 22:18:55
 
我的印象,这种构架只适合低压,高压应用恐没优势。
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-29 15:14:30
  • 倒数6
 
高压的确不好做,如果能做到高压可靠关断导通的话,结果很诱人。实际测量在500WPFC时,效率可以做到超过99%。目前,我的实验结果是98.82%
nc965
  • 积分:44729
  • |
  • 主题:113
  • |
  • 帖子:14705
积分:44729
版主
  • 2018-8-29 16:12:23
  • 倒数2
 
拿掉那几个吸收电阻效率就上去了。电流毛刺或许可用饱和电感(功率磁珠)化解。
nc965
  • 积分:44729
  • |
  • 主题:113
  • |
  • 帖子:14705
积分:44729
版主
  • 2018-8-10 12:43:42
 
一级运放都嫌多,两级运放更容易飙
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-13 09:53:20
 
第二级放大只是一个电压跟随器,这个应该也增加干扰么?这个怎么解析?
nc965
  • 积分:44729
  • |
  • 主题:113
  • |
  • 帖子:14705
积分:44729
版主
  • 2018-8-13 09:54:20
 
说的就是你关心的滤波参数问题
xkw1cn
  • 积分:113875
  • |
  • 主题:37501
  • |
  • 帖子:52422
积分:113875
版主
  • 2018-8-21 01:02:37
  • 倒数9
 
GaN太快了,共模噪音比MOSFET大几个数量级。让东方不败来;PP也得电冒烟啊。
只要使能躲开开关沿再测就没事了。
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-29 15:12:09
  • 倒数8
 
开关沿躲开了,可是现在又有其他问题了。就是开通速度太快,上管开通时,下管G极由于弥勒效应应该有震荡,估计管子内部导通了。所以现在没法做到高压输出,目前只做到200V+。
xkw1cn
  • 积分:113875
  • |
  • 主题:37501
  • |
  • 帖子:52422
积分:113875
版主
  • 2018-8-21 01:00:17
  • 倒数10
 
显然MCU检测没有躲开关沿。开关噪音直接干扰了。改phonewave吧!
Nikita_Yang
  • 积分:100
  • |
  • 主题:2
  • |
  • 帖子:22
积分:100
LV2
本网技师
  • 2018-8-29 15:12:48
  • 倒数7
 
电流过流干扰解决了,现在是驱动弥勒效应影响问题。
热门技术、经典电源设计资源推荐

世纪电源网总部

地 址:天津市南开区黄河道大通大厦16层

电 话:400-022-5587

传 真:(022)27690960

邮 编:300110

E-mail:21dy#21dianyuan.com(#换成@)

世纪电源网分部

广 东:(0755)28285637 /(13823562357)

北 京:(010)69525295 /(15901552591)

上 海:(021)24200688 /(13585599008)

香 港:HK(852)92121212

China(86)15220029145

中国电源学会

地 址:天津市南开区黄河道大通大厦5层

电 话:(022)27680796

传 真:(022)27687886

E-mail:cpss#cpss.org.cn(#换成@)

网站简介 | 网站帮助 | 意见反馈 | 联系我们 | 广告服务 | 法律声明 | 友情链接 | 清除Cookie | 小黑屋 | 不良信息举报

Copyright 2008-2018 21dianyuan.com All Rights Reserved    备案许可证号为:津ICP备10002348