世纪电源网社区logo
社区
Datasheet
标题
返回顶部
已解决

单端反激电源,一上电就听到尖锐的声音是怎么回事?

[复制链接]
查看: 4077 |回复: 27
1
烟花易冷
  • 积分:1217
  • |
  • 主题:39
  • |
  • 帖子:286
积分:1217
LV6
高级工程师
  • 2018-5-11 08:47:33
10问答币
频率36KHz;初次级匝比4.2:1(1.1mH:63uH),辅助绕组与次级匝比1:1;
输出12V/3A;
预估效率0.8;
上电后听到尖锐的声音(40V/1A的直流电),这是什么原因?
5O(~`[70H~C9KNJ2B65}Z%9.png

最佳答案

查看完整内容

楼主这情况应该是驱动输出频率,与变压器工作频率不匹配导致的,楼主应该对驱动输出频率下手
anthony
  • 积分:2955
  • |
  • 主题:14
  • |
  • 帖子:301
积分:2955
LV8
副总工程师
  • 2018-5-11 09:24:42
 
实测功率MOSFET 的Vds波形是怎样?

评分

参与人数 121币 +5收起理由
世纪电源网-九天 + 5

查看全部评分

fengbin
  • 积分:1823
  • |
  • 主题:57
  • |
  • 帖子:228
积分:1823
LV6
高级工程师
  • 2018-5-11 09:58:27
 
变压器绕的有问题

评分

参与人数 121币 +5收起理由
世纪电源网-九天 + 5

查看全部评分

能源消耗
  • 积分:5122
  • |
  • 主题:33
  • |
  • 帖子:1568
积分:5122
LV8
副总工程师
  • 2018-5-11 10:06:31
 
电感量都1.1mH, 初级多少圈?气息放多少。功率都36W了。磁芯AE值也不会小,电压才50V啊,不可能那么大电感量吧?

评分

参与人数 121币 +5收起理由
世纪电源网-九天 + 5

查看全部评分

烟花易冷
  • 积分:1217
  • |
  • 主题:39
  • |
  • 帖子:286
积分:1217
LV6
高级工程师
  • 2018-5-12 18:32:48
 
我也不会设计变压器,只能根据赵修科的《磁性元件理论及设计》,里面的公式设计的。
hwx-555
  • 积分:18133
  • |
  • 主题:51
  • |
  • 帖子:5661
积分:18133
LV10
总工程师
  • 2018-5-11 10:15:51
 
输入40V,匝比这么大,变压器没设计好

评分

参与人数 121币 +5收起理由
世纪电源网-九天 + 5

查看全部评分

烟花易冷
  • 积分:1217
  • |
  • 主题:39
  • |
  • 帖子:286
积分:1217
LV6
高级工程师
  • 2018-5-12 18:33:33
  • 倒数10
 
匝比才4.2:1.这也大吗?
hwx-555
  • 积分:18133
  • |
  • 主题:51
  • |
  • 帖子:5661
积分:18133
LV10
总工程师
  • 2018-5-14 08:30:51
  • 倒数7
 
输入40V ?输出12V?
木木很-shy
  • 积分:2466
  • |
  • 主题:1
  • |
  • 帖子:251
积分:2466
LV8
副总工程师
  • 2018-5-11 11:43:02
 
此时反馈端1脚波形啥样啊?

评分

参与人数 121币 +5收起理由
世纪电源网-九天 + 5

查看全部评分

z443233785
  • 积分:1311
  • |
  • 主题:4
  • |
  • 帖子:352
积分:1311
LV6
高级工程师
  • 2018-5-11 11:52:07
 
变压器没浸油吧

评分

参与人数 121币 +5收起理由
世纪电源网-九天 + 5

查看全部评分

Ast200902
  • 积分:769
  • |
  • 主题:0
  • |
  • 帖子:203
积分:769
LV6
高级工程师
  • 2018-5-11 12:23:06
 
VT=NBA算一算B是多少.

评分

参与人数 121币 +5收起理由
世纪电源网-九天 + 5

查看全部评分

Ast200902
  • 积分:769
  • |
  • 主题:0
  • |
  • 帖子:203
积分:769
LV6
高级工程师
  • 2018-5-11 12:40:37
 
粗略一算, Ae要很大, 应是磁饱和.

Ast200902
  • 积分:769
  • |
  • 主题:0
  • |
  • 帖子:203
积分:769
LV6
高级工程师
  • 2018-5-11 12:49:50
 
V
40
F
3.60E+04
T
2.78E-05
D
4.55E-01
Ton
1.26E-05
N
40
B
0.25


A
5.05E-05
Ast200902
  • 积分:769
  • |
  • 主题:0
  • |
  • 帖子:203
积分:769
LV6
高级工程师
  • 2018-5-11 13:07:42
 
用LI=NBA, 找I饱和值. I=0.45A


L
1.10E-03
N
40
B
0.25
A
5.05E-05


I
4.59E-01


wangdongchun
  • 积分:7590
  • |
  • 主题:22
  • |
  • 帖子:1745
积分:7590
LV8
副总工程师
  • 2018-5-11 12:50:53
 
楼主的变压器绕制恐怕有问题,还有输出端有无问题

评分

参与人数 121币 +5收起理由
世纪电源网-九天 + 5

查看全部评分

lovelee
  • 积分:2715
  • |
  • 主题:18
  • |
  • 帖子:259
积分:2715
LV8
副总工程师
  • 2018-5-11 13:11:16
 
楼主听到的尖叫声是变压器发出来的吗?还是UC芯片,估计是变压器设计有问题。检查分析下,尖叫声说明频率很高。

评分

参与人数 121币 +5收起理由
世纪电源网-九天 + 5

查看全部评分

烟花易冷
  • 积分:1217
  • |
  • 主题:39
  • |
  • 帖子:286
积分:1217
LV6
高级工程师
  • 2018-5-22 15:32:32
  • 倒数4
 
你好,我之后重新设计了变压器,频率还是按照36.6K计算的,现在的变压器参数是初次级匝比27:13,EE35磁芯,气隙大概是0.7mm。我下面把测试的一些情况写下来给您参考参考。
Input(输入)       负载(Load)      变压器声音响与否              Output(输出)

40V/2A              60Ω                           响                                   11.5V


40V/2A              50Ω                           响                                   11.7V


40V/2A              40Ω                           响                                   11.6V


40V/2A              30Ω                          不 响                                11V


40V/2A              20Ω                          来不及听声音,因为一上电负载跳到一定电压立刻再跳到零电压


不清楚原因是为什么,明明是按照输入40-50V,效率80%,输出12V/3A设计的CCM电流模式设计的,也测试了芯片的频率和要求的频率符合,为什么变压器还是会有声音?还有为什么负载变成20Ω的时候一上电负载跳到一定电压立刻再跳到零电压,理论应该可以接3欧姆的电阻才对,这是不是由于变压器的传递效率比80%更低,所以导致初级电流太大,芯片过流保护了?
鑫越电子
  • 积分:4446
  • |
  • 主题:54
  • |
  • 帖子:624
积分:4446
LV8
副总工程师
  • 2018-5-11 21:06:32
 
查一下变压器和电容参数

评分

参与人数 121币 +5收起理由
世纪电源网-九天 + 5

查看全部评分

niyin
  • niyin
  • 离线
  • LV6
  • 高级工程师
  • 积分:690
  • |
  • 主题:2
  • |
  • 帖子:139
积分:690
LV6
高级工程师
  • 2018-5-12 12:15:42
 
楼主这情况应该是驱动输出频率,与变压器工作频率不匹配导致的,楼主应该对驱动输出频率下手

评分

参与人数 121币 +10收起理由
世纪电源网雪花 + 10

查看全部评分

烟花易冷
  • 积分:1217
  • |
  • 主题:39
  • |
  • 帖子:286
积分:1217
LV6
高级工程师
  • 2018-5-12 18:34:55
  • 倒数9
 
对,找出来原因了,是你说的这个原因。谢谢啦。
烟花易冷
  • 积分:1217
  • |
  • 主题:39
  • |
  • 帖子:286
积分:1217
LV6
高级工程师
  • 2018-5-22 15:32:57
  • 倒数3
 
你好,我之后重新设计了变压器,频率还是按照36.6K计算的,现在的变压器参数是初次级匝比27:13,EE35磁芯,气隙大概是0.7mm。我下面把测试的一些情况写下来给您参考参考。
Input(输入)       负载(Load)      变压器声音响与否              Output(输出)

40V/2A              60Ω                           响                                   11.5V


40V/2A              50Ω                           响                                   11.7V


40V/2A              40Ω                           响                                   11.6V


40V/2A              30Ω                          不 响                                11V


40V/2A              20Ω                          来不及听声音,因为一上电负载跳到一定电压立刻再跳到零电压


不清楚原因是为什么,明明是按照输入40-50V,效率80%,输出12V/3A设计的CCM电流模式设计的,也测试了芯片的频率和要求的频率符合,为什么变压器还是会有声音?还有为什么负载变成20Ω的时候一上电负载跳到一定电压立刻再跳到零电压,理论应该可以接3欧姆的电阻才对,这是不是由于变压器的传递效率比80%更低,所以导致初级电流太大,芯片过流保护了?

niyin
  • niyin
  • 离线
  • LV6
  • 高级工程师
  • 积分:690
  • |
  • 主题:2
  • |
  • 帖子:139
积分:690
LV6
高级工程师
  • 2018-5-12 12:18:46
 
驱动输出频率与变压器工作频率不匹配是调不好空载电流的
z443233785
  • 积分:1311
  • |
  • 主题:4
  • |
  • 帖子:352
积分:1311
LV6
高级工程师
  • 2018-5-14 09:07:45
  • 倒数6
 
请教一下,驱动输出频率与变压器工作频率不匹配,这是什么原因造成的?

niyin
  • niyin
  • 离线
  • LV6
  • 高级工程师
  • 积分:690
  • |
  • 主题:2
  • |
  • 帖子:139
积分:690
LV6
高级工程师
  • 2018-5-14 11:37:39
  • 倒数5
 
这没什么原因的,只要调整好驱动输出频率就可以的
烟花易冷
  • 积分:1217
  • |
  • 主题:39
  • |
  • 帖子:286
积分:1217
LV6
高级工程师
  • 2018-5-22 15:33:46
  • 倒数2
 
你好,我之后重新设计了变压器,频率还是按照36.6K计算的,现在的变压器参数是初次级匝比27:13,EE35磁芯,气隙大概是0.7mm。我下面把测试的一些情况写下来给您参考参考。
Input(输入)       负载(Load)      变压器声音响与否              Output(输出)

40V/2A              60Ω                           响                                   11.5V


40V/2A              50Ω                           响                                   11.7V


40V/2A              40Ω                           响                                   11.6V


40V/2A              30Ω                          不 响                                11V


40V/2A              20Ω                          来不及听声音,因为一上电负载跳到一定电压立刻再跳到零电压


不清楚原因是为什么,明明是按照输入40-50V,效率80%,输出12V/3A设计的CCM电流模式设计的,也测试了芯片的频率和要求的频率符合,为什么变压器还是会有声音?还有为什么负载变成20Ω的时候一上电负载跳到一定电压立刻再跳到零电压,理论应该可以接3欧姆的电阻才对,这是不是由于变压器的传递效率比80%更低,所以导致初级电流太大,芯片过流保护了?

niyin
  • niyin
  • 离线
  • LV6
  • 高级工程师
  • 积分:690
  • |
  • 主题:2
  • |
  • 帖子:139
积分:690
LV6
高级工程师
最新回复
  • 2018-5-23 01:14:28
  • 倒数1
 
这个改变负载功率,变压器就有声音是因为,输出放电时间改变了,造成反馈回3842的开启和关闭时间也跟着改变,也改变了3842的输出频率这个可以用示波器看的出来的,C12和C8这两个电容容值也要改变下,这个容值要你自己根据带的不同负载做个综合的取值,还有就是变压器你绕好了一定要浸漆固定好线圈,因为做了闭环在不同的负载下,放电改变了3842输出频率造成线圈在不同的频率下会随着频率而抖动,所以也会造成变压器有声音的原因,再就是R19R11R18这三个限流电阻,阻值可以减低一点,W数取大点,因为有效率这层关系在,应该要留点余量,不能按AC220来限流值,
cyx7610
  • 积分:9580
  • |
  • 主题:78
  • |
  • 帖子:1969
积分:9580
LV8
副总工程师
  • 2018-5-12 15:27:23
 
用RCC还是用什么控制IC线路?
烟花易冷
  • 积分:1217
  • |
  • 主题:39
  • |
  • 帖子:286
积分:1217
LV6
高级工程师
  • 2018-5-12 18:35:35
  • 倒数8
 
UC3842
热门技术、经典电源设计资源推荐

世纪电源网总部

地 址:天津市南开区黄河道大通大厦16层

电 话:400-022-5587

传 真:(022)27690960

邮 编:300110

E-mail:21dy#21dianyuan.com(#换成@)

世纪电源网分部

广 东:(0755)28285637 /(13823562357)

北 京:(010)69525295 /(15901552591)

上 海:(021)24200688 /(13585599008)

香 港:HK(852)92121212

China(86)15220029145

中国电源学会

地 址:天津市南开区黄河道大通大厦5层

电 话:(022)27680796

传 真:(022)27687886

E-mail:cpss#cpss.org.cn(#换成@)

网站简介 | 网站帮助 | 意见反馈 | 联系我们 | 广告服务 | 法律声明 | 友情链接 | 清除Cookie | 小黑屋 | 不良信息举报

Copyright 2008-2018 21dianyuan.com All Rights Reserved    备案许可证号为:津ICP备10002348