世纪电源网社区logo
社区
Datasheet
标题
返回顶部
未解决

TL494做的升压电源问题

[复制链接]
查看: 313 |回复: 27
1
powerstud2018
  • 积分:115
  • |
  • 主题:3
  • |
  • 帖子:19
积分:115
LV2
本网技师
  • 2018-10-9 17:13:03
20问答币
麻烦各位帮忙给看看这个电源,用TL494做的升压电路,输入9V-26V,输出28V-54V,本来希望是输入电流能够到20A,调试的时候输入是12V,输出48V,但是现在电流在17A、18A的时候MOS就穿了。本来从拆下的MOS上看感觉是过热损坏的,所以就再更换,然后加风扇上电,但是刚一运行大概十几秒就又坏了(负载减小,输入电流大概到5A左右),更换过TL494也不行,还是工作十几秒就损坏。而且我的两块完全一样的板子,都是这个情况,刚开始上电15A以下基本没问题,到了大电流把MOS烧坏后就修不好了,只剩电阻电容没换了。
麻烦各位给看看是不是哪的参数不正确。
电路里面的R19和R20两个MOS驱动限流电阻原来用的是3.3欧姆,但是因为MOS开通的时候震荡太厉害了,就改成20欧姆了,但还是有震荡。



1.jpg
2.jpg

5.jpg


绿色是驱动信号,黄色是MOS的D极上的电压,红色是电感电流。

6.jpg

nc965
  • 积分:43394
  • |
  • 主题:113
  • |
  • 帖子:14282
积分:43394
版主
  • 2018-10-9 18:36:35
 
电感电流信号不对劲
powerstud2018
  • 积分:115
  • |
  • 主题:3
  • |
  • 帖子:19
积分:115
LV2
本网技师
  • 2018-10-10 09:23:49
 
22.png

这个是之前做的一个电源的波形,看起来确实有点区别,但是这次的功率大,不知道跟功率有没有关系
powerstud2018
  • 积分:115
  • |
  • 主题:3
  • |
  • 帖子:19
积分:115
LV2
本网技师
  • 2018-10-10 10:02:21
 
另外还有个问题,就是效率特别低,我看了一下测试的效率,感觉是因为效率过低导致的,但又不知道怎么样提高效率。在低压输入的时候效率特别低。
   
02.jpg          01.jpg       
效率85.2%                                         92.9%
同样输出52W,输入12V的时候比24V的时候多损耗了5W

03.jpg     05.jpg
              效率74.6%                                             效率92.8%

同样输出112W,输入12V的时候比输入24V的时候多损耗了30W,一共损耗接近40W

04.jpg












nc965
  • 积分:43394
  • |
  • 主题:113
  • |
  • 帖子:14282
积分:43394
版主
  • 2018-10-10 10:35:41
 
1、Boost电路应该是很好调试的,效率也不会低,重点在于你要把控工况,也就是占空比与理论升压幅度的吻合程度,你仔细看看了。
2、此外电流采样明显有滞后和畸变,如果此信号用于环路控制就有问题,仅用于保护可暂时不理会。
3、1楼电流采样波形反应电感量明显偏大(4楼是合适的)。
4、输出54V而二极管用60V电压等级比较冒险了,余量不足,加上电路布局的不合理(三圈两地没做好),击穿是大概率事件。
5、主要发热应该在二极管上,热击穿几率很大。
powerstud2018
  • 积分:115
  • |
  • 主题:3
  • |
  • 帖子:19
积分:115
LV2
本网技师
  • 2018-10-10 14:25:39
 
谢谢您的回复。就是您说的占空比跟升压比我感觉还是吻合的,主要就是那个电流确实滞后了,但不知道是什么原因。还有就是您说发热在二极管上,但是输出电流只有不到5A,二极管是两个20A的,一共就是40A,这个余量也不足吗?电压确实余量有点小了。还有那个二极管测量好像没坏。
另外就是那个MOS管的选择,有个疑问,一般应该留多大的余量,我这个设计里面峰值电流大概20A,我用了两个IRFB3207,一个3207的电流是75A,两个的话应该150A,但是还是好像不够。


从效率测试的数据上看,因为增大输出功率引起的损耗并不是很大,这是不是能说明输出二极管上的损耗比较小,主要损耗是在前端MOS跟电感上呢?
nc965
  • 积分:43394
  • |
  • 主题:113
  • |
  • 帖子:14282
积分:43394
版主
  • 2018-10-10 15:55:55
 
如果你的功率在250W左右,那么二极管和MOS都只用1只应该是可以的。说主要发热在二极管上,意思是MOS发热应该低于二极管,但你的情况相反,建议测试一下MOS的内阻(目前的表现疑似假货)。此外工况需要进一步明确(恒功率?),电感也是需要优化(感量和抗饱和裕度)的。
powerstud2018
  • 积分:115
  • |
  • 主题:3
  • |
  • 帖子:19
积分:115
LV2
本网技师
  • 2018-10-10 18:38:50
 
谢谢您了,还有个问题,下面图中的这部分是不是也有问题,积分的电容跟电阻接到基准电压上了,是不是也没什么作用了?

12.jpg

nc965
  • 积分:43394
  • |
  • 主题:113
  • |
  • 帖子:14282
积分:43394
版主
  • 2018-10-10 18:58:55
 
FB是运放输出的话,这样是可以的,不过是多余的(仅用一组RC即可),画蛇添足。
powerstud2018
  • 积分:115
  • |
  • 主题:3
  • |
  • 帖子:19
积分:115
LV2
本网技师
  • 2018-10-11 08:55:55
 
C5是多余的?还是电压或者电流上只用一组就可以?
powerstud2018
  • 积分:115
  • |
  • 主题:3
  • |
  • 帖子:19
积分:115
LV2
本网技师
  • 2018-10-11 09:10:03
  • 倒数10
 
只能说是恒压,不是恒功率,输出电压一般是48V,输入12V(也有可能是24V)
xkw1cn
  • 积分:113599
  • |
  • 主题:37499
  • |
  • 帖子:52350
积分:113599
版主
  • 2018-10-9 21:43:07
 
感觉象没装散热器。。。拍个你的电路照片看看。
powerstud2018
  • 积分:115
  • |
  • 主题:3
  • |
  • 帖子:19
积分:115
LV2
本网技师
  • 2018-10-10 09:25:44
 
散热片确实装了

真武阁
  • 积分:4971
  • |
  • 主题:25
  • |
  • 帖子:1477
积分:4971
LV8
副总工程师
  • 2018-10-10 14:33:41
 
看电感电流有点趋饱和的样子
powerstud2018
  • 积分:115
  • |
  • 主题:3
  • |
  • 帖子:19
积分:115
LV2
本网技师
  • 2018-10-10 14:52:46
 
08.jpg


用的这个磁环,绕了23匝,那饱和电流是不是应该是700/23=30A (我不知道我理解的对不对),现在是20A
nc965
  • 积分:43394
  • |
  • 主题:113
  • |
  • 帖子:14282
积分:43394
版主
  • 2018-10-10 18:56:56
 
这个电感饱和了,不能用,要吗两环并(16匝),要吗77550(31匝)
利兹线规格.png
st.you
  • 积分:10110
  • |
  • 主题:8
  • |
  • 帖子:2964
积分:10110
LV10
总工程师
  • 2018-10-10 16:07:20
 
可以试试多个电流小一点的MOS并联,你现在用的IRF3207,栅极电容太大了,开关速度慢,损耗大
powerstud2018
  • 积分:115
  • |
  • 主题:3
  • |
  • 帖子:19
积分:115
LV2
本网技师
  • 2018-10-12 09:02:55
  • 倒数8
 
我手头上刚好有个3205,同一个品牌的,我看了一下栅极电容小一半,我换了后测试,但感觉基本效率提升很小。

企业微信截图_20181012085349.png 企业微信截图_20181012085632.png
4.jpg           5.jpg




powerstud2018
  • 积分:115
  • |
  • 主题:3
  • |
  • 帖子:19
积分:115
LV2
本网技师
  • 2018-10-12 09:40:42
  • 倒数7
 

后来又降低频率,从原来100kHz降低到40kHz,效率提升了大概12个百分点。从换管子上看好像不是开关损耗过大,但是从降频率来看又是开关损耗比较大。
7.jpg 8.jpg


st.you
  • 积分:10110
  • |
  • 主题:8
  • |
  • 帖子:2964
积分:10110
LV10
总工程师
  • 2018-10-12 10:15:02
  • 倒数6
 
栅极驱动上下沿实测一下波形
powerstud2018
  • 积分:115
  • |
  • 主题:3
  • |
  • 帖子:19
积分:115
LV2
本网技师
  • 2018-10-12 11:12:19
  • 倒数5
 
上面两个图是40K的时候的,下图两个是100K的,绿色是驱动波形


40k01.jpg 40k03.jpg
100K02.jpg 100K03.jpg




st.you
  • 积分:10110
  • |
  • 主题:8
  • |
  • 帖子:2964
积分:10110
LV10
总工程师
  • 2018-10-12 11:45:39
  • 倒数4
 
可以定义为慢了,如果不想换控制芯片494,那就加一个MOS驱动芯片吧。
powerstud2018
  • 积分:115
  • |
  • 主题:3
  • |
  • 帖子:19
积分:115
LV2
本网技师
  • 2018-10-12 13:13:55
  • 倒数3
 
谢谢您,还想跟您问一下,就是我之前那个限流电阻是2.2欧姆的,但是那样的话开通震荡很厉害,这个震荡一般怎么样能消除或者减小呢?
0000.jpg
st.you
  • 积分:10110
  • |
  • 主题:8
  • |
  • 帖子:2964
积分:10110
LV10
总工程师
  • 2018-10-12 14:24:03
  • 倒数2
 
这个是密勒效应造成的,硬开关的BOOST只能寄希望于开关管特性了,换个电流又大栅极电容又小的MOS吧。
st.you
  • 积分:10110
  • |
  • 主题:8
  • |
  • 帖子:2964
积分:10110
LV10
总工程师
  • 2018-10-10 16:31:53
 
我最近也做了一款输入功率比你这个小一些的BOOST,输入12V,输出80V1A 最大。 QQ图片20181010162642.png }84TKF17CU_BB8W6Z`5FWG6.png
nc965
  • 积分:43394
  • |
  • 主题:113
  • |
  • 帖子:14282
积分:43394
版主
  • 2018-10-10 18:34:44
 
晒晒同步整流部分
st.you
  • 积分:10110
  • |
  • 主题:8
  • |
  • 帖子:2964
积分:10110
LV10
总工程师
  • 2018-10-11 09:52:14
  • 倒数9
 
没有呢怎么晒?   右边的MOS是用线性的方式来防负载接入瞬间冲击的。
qq2813801825
  • 积分:323
  • |
  • 主题:2
  • |
  • 帖子:33
积分:323
LV4
初级工程师
最新回复
  • 2018-10-13 21:11:00
  • 倒数1
 
这个要赞一个哈哈,我家的升压还是可以的嘛
热门技术、经典电源设计资源推荐

世纪电源网总部

地 址:天津市南开区黄河道大通大厦16层

电 话:400-022-5587

传 真:(022)27690960

邮 编:300110

E-mail:21dy#21dianyuan.com(#换成@)

世纪电源网分部

广 东:(0755)28285637 /(13823562357)

北 京:(010)69525295 /(15901552591)

上 海:(021)24200688 /(13585599008)

香 港:HK(852)92121212

China(86)15220029145

中国电源学会

地 址:天津市南开区黄河道大通大厦5层

电 话:(022)27680796

传 真:(022)27687886

E-mail:cpss#cpss.org.cn(#换成@)

网站简介 | 网站帮助 | 意见反馈 | 联系我们 | 广告服务 | 法律声明 | 友情链接 | 清除Cookie | 小黑屋 | 不良信息举报

Copyright 2008-2018 21dianyuan.com All Rights Reserved    备案许可证号为:津ICP备10002348