世纪电源网社区logo
社区
Datasheet
标题
返回顶部
未解决

反激变换器,芯片UC3844不能正常工作

[复制链接]
查看: 1847 |回复: 18
1
yk123
  • yk123
  • 离线
  • LV6
  • 高级工程师
  • 积分:473
  • |
  • 主题:29
  • |
  • 帖子:83
积分:473
LV6
高级工程师
  • 2017-7-7 11:07:35
10问答币
单独测试芯片,芯片供电端15V,参考电压输出4.6V
但是把芯片装在反激变换器的板子上波形就不对了
这是什么原因?

这是原理图

这是原理图

芯片的供电端,7脚

芯片的供电端,7脚

芯片的参考电压输出,8脚

芯片的参考电压输出,8脚

MOSFET的G端电压波形

MOSFET的G端电压波形
h8f10
  • h8f10
  • 离线
  • LV8
  • 副总工程师
  • 积分:3284
  • |
  • 主题:11
  • |
  • 帖子:757
积分:3284
LV8
副总工程师
  • 2017-7-7 11:11:34
 
CS端到1V没,1V就触发过流保护
yk123
  • yk123
  • 离线
  • LV6
  • 高级工程师
  • 积分:473
  • |
  • 主题:29
  • |
  • 帖子:83
积分:473
LV6
高级工程师
  • 2017-7-7 11:36:09
 
过流保护的采样电阻是0.5Ω ,外接的保险丝是2A的,应该不会过流保护

这是CS端波形的

这是CS端波形的
h8f10
  • h8f10
  • 离线
  • LV8
  • 副总工程师
  • 积分:3284
  • |
  • 主题:11
  • |
  • 帖子:757
积分:3284
LV8
副总工程师
  • 2017-7-7 11:52:22
 
5V一格啊?早过流了。
h8f10
  • h8f10
  • 离线
  • LV8
  • 副总工程师
  • 积分:3284
  • |
  • 主题:11
  • |
  • 帖子:757
积分:3284
LV8
副总工程师
  • 2017-7-7 11:53:25
 
还有示波器不是这样看的,拉开看细节啊。幅值的话用合适的量程。
yk123
  • yk123
  • 离线
  • LV6
  • 高级工程师
  • 积分:473
  • |
  • 主题:29
  • |
  • 帖子:83
积分:473
LV6
高级工程师
  • 2017-7-7 12:50:15
 
确实有一个尖脉冲3.3V,是因为启动的时候电流太大了吗?应该怎么改进啊?
yk123
  • yk123
  • 离线
  • LV6
  • 高级工程师
  • 积分:473
  • |
  • 主题:29
  • |
  • 帖子:83
积分:473
LV6
高级工程师
  • 2017-7-7 16:11:30
  • 倒数6
 
是不是因为Rs两端的滤波器设计不合理,没有把上电瞬间的尖峰电压滤除
kfhzy
  • kfhzy
  • 离线
  • LV6
  • 高级工程师
  • 积分:747
  • |
  • 主题:16
  • |
  • 帖子:76
积分:747
LV6
高级工程师
  • 2017-7-7 11:40:48
 
MOS管栅极波形什么样?看样子应该是MOS没有正常工作
yk123
  • yk123
  • 离线
  • LV6
  • 高级工程师
  • 积分:473
  • |
  • 主题:29
  • |
  • 帖子:83
积分:473
LV6
高级工程师
  • 2017-7-7 12:47:59
 
确实是mos管没有工作,因为芯片工作不正常
kfhzy
  • kfhzy
  • 离线
  • LV6
  • 高级工程师
  • 积分:747
  • |
  • 主题:16
  • |
  • 帖子:76
积分:747
LV6
高级工程师
  • 2017-7-7 14:06:30
 
额,不能这么讲,一般UC3844 芯片8脚有3V以上电压时,基本上是准备工作状态,出问题就要看外部电路了,外部不给力,辅助回路不给继续供电,所以不能充分输出5V电压。所以,这时候观察 6脚驱动波形很重要

YTDFWANGWEI
  • 积分:106880
  • |
  • 主题:139
  • |
  • 帖子:45539
积分:106880
版主
  • 2017-7-7 14:41:51
  • 倒数10
 
变压器3脚波形什么样子?
yk123
  • yk123
  • 离线
  • LV6
  • 高级工程师
  • 积分:473
  • |
  • 主题:29
  • |
  • 帖子:83
积分:473
LV6
高级工程师
  • 2017-7-7 14:46:51
  • 倒数9
 
3脚的波形没有测
YTDFWANGWEI
  • 积分:106880
  • |
  • 主题:139
  • |
  • 帖子:45539
积分:106880
版主
  • 2017-7-7 15:08:54
  • 倒数8
 
1、从IC的8脚、1脚及6脚波形来看,三个波形是相符的,驱动信号应该在100ms左右,但3脚波形却只有一个尖尖的脉冲,所以怀疑IC3脚波形测试有误。2、不能正常工作的原因很简单,就是辅助绕组没有及时提供IC工作的后续能量,问题有可能是以下几个1)绕组匝数不够2)绕组同名端有问题3)辅助绕组串联的那个电阻阻值太大了。
kfhzy
  • kfhzy
  • 离线
  • LV6
  • 高级工程师
  • 积分:747
  • |
  • 主题:16
  • |
  • 帖子:76
积分:747
LV6
高级工程师
  • 2017-7-7 15:41:20
  • 倒数7
 
也许是mos管坏了呢
YTDFWANGWEI
  • 积分:106880
  • |
  • 主题:139
  • |
  • 帖子:45539
积分:106880
版主
  • 2017-7-7 16:24:52
  • 倒数5
 
如果MOS管坏了,还能有持续100mS的驱动?
yk123
  • yk123
  • 离线
  • LV6
  • 高级工程师
  • 积分:473
  • |
  • 主题:29
  • |
  • 帖子:83
积分:473
LV6
高级工程师
  • 2017-7-7 16:43:10
  • 倒数4
 
会不会是我Rs两端的rc滤波器设计不合理,没有把启动时的大电流滤掉,芯片3脚过流保护
或者变换器空载,没有起激,辅助绕组没有供电
YTDFWANGWEI
  • 积分:106880
  • |
  • 主题:139
  • |
  • 帖子:45539
积分:106880
版主
  • 2017-7-8 08:13:58
  • 倒数2
 
我想,与其在这里猜测,不如实际测量下,你说呢。
kfhzy
  • kfhzy
  • 离线
  • LV6
  • 高级工程师
  • 积分:747
  • |
  • 主题:16
  • |
  • 帖子:76
积分:747
LV6
高级工程师
  • 2017-7-7 18:17:04
  • 倒数3
 
MOS坏了,UC3844会每隔一段时间驱动一次,每次驱动都是一组脉冲

YTDFWANGWEI
  • 积分:106880
  • |
  • 主题:139
  • |
  • 帖子:45539
积分:106880
版主
最新回复
  • 2017-7-8 08:14:24
  • 倒数1
 
那你说的这个坏,除非GDS都是断路,而不是短路。
热门技术、经典电源设计资源推荐

世纪电源网总部

地 址:天津市南开区黄河道大通大厦8层

电 话:400-022-5587

传 真:(022)27690960

邮 编:300110

E-mail:21dy#21dianyuan.com(#换成@)

世纪电源网分部

广 东:(0755)28285637 /(13823562357)

北 京:(010)69525295 /(15901552591)

上 海:(021)24200688 /(13585599008)

香 港:HK(852)92121212

China(86)15220029145

网站简介 | 网站帮助 | 意见反馈 | 联系我们 | 广告服务 | 法律声明 | 友情链接 | 清除Cookie | 小黑屋 | 不良信息举报 | 网站举报

Copyright 2008-2022 21dianyuan.com All Rights Reserved    备案许可证号为:津ICP备10002348